PopularFX
Home Help Search Login Register
Welcome,Guest. Please login or register.
2017-12-13, 09:08:58
News: Check out the Benches; a place for people to moderate their own thread and document their builds and data.
If you would like your own Bench, please PM an Admin.
Most Benches are visible only to members.

Pages: 1 2 3 4 [5]
Author Topic: Rigol DS1054Z -- Features, Usage, and... BUGS !!  (Read 30202 times)

Hero Member
*****

Posts: 1107
What's the Channel 1 bug? I think I've encountered just about all of them, but I can't think of which one you mean. Can you describe it further?


---------------------------
"The easiest person to fool is yourself" -- Richard Feynman
   
Hero Member
*****

Posts: 1178
... .-.. .. -.. . .-.
Oh, shoot, if it doesn't exist then i'm going to feel embarrassed !
Well, the basis was that if Channels 1 and 3 are used together, the readings on Channel 1 could be messed up. Other combinations or 3 channels/4 channels being fine.
That's why I use Channel 2 for single measuring, then if another thing needs measuring during the session, i'm sure to not have 1 and 3 be the channels.

If that doesn't exist then i've got into an unneeded habit with an unknown source.


---------------------------
ʎɐqǝ ɯoɹɟ pɹɐoqʎǝʞ ɐ ʎnq ɹǝʌǝu
   

Hero Member
*****

Posts: 1107
Uh OK, I think I know what you mean. There seemed to be a lot of measurement crosstalk between channels in some cases, such that even a channel set to GND coupling and with no input at all, would give weird measurement readings especially RMS values when another channel was in use.

See example shot below. Is this the problem you mean?

This has actually been fixed in the most recent firmware update, I believe.

Most recent firmware is 00.04.04.03.02, identified in the short System Info screen as 00.04.04.SP3

As far as I can tell the only major bug remaining, that could be fixed in software, is the "Pluses" spelling error.


---------------------------
"The easiest person to fool is yourself" -- Richard Feynman
   
Hero Member
*****

Posts: 1178
... .-.. .. -.. . .-.
Yes, that looks right, although i'm not sure of the speciifics. It wasn't a huge deal, just wrong and could be avoided. I find it quite ironic that in your shot it's Channel 2 with the bug !
Good to know about the firmware fix...mine is still stock and hasn't had the unlock done on it either. Perhaps it would be wise to do both.

 


---------------------------
ʎɐqǝ ɯoɹɟ pɹɐoqʎǝʞ ɐ ʎnq ɹǝʌǝu
   

Hero Member
*****

Posts: 1107
Yes, definitely install the latest firmware. The firmware and instructions and release notes are here:

http://beyondmeasure.rigoltech.com/acton/fs/blocks/showLandingPage/a/1579/p/p-0019/t/page/fm/0

Unlocking is good too, and you needn't feel guilty about it since Rigol are now giving the options away free with new purchases of the scope. (They think Siglent is about to come out with a really exciting scope in the same price point.)


---------------------------
"The easiest person to fool is yourself" -- Richard Feynman
   
Hero Member
*****

Posts: 1178
... .-.. .. -.. . .-.
Many thanks  O0
That's good news about the unlock...I could run it without the curtains drawn or the lights dimmed. Which is quite handy, because we don't have curtains and the bulbs don't dim  lol


---------------------------
ʎɐqǝ ɯoɹɟ pɹɐoqʎǝʞ ɐ ʎnq ɹǝʌǝu
   
Pages: 1 2 3 4 [5]
« previous next »


 

Home Help Search Login Register
Theme © PopularFX | Based on PFX Ideas! | Scripts from iScript4u 2017-12-13, 09:08:58